AudiogoN
Search Buy Sell Learn MyPage
 Learn > Forums > Speakers > 1108804115  Start New Thread | Log In | Bookmark This

  Replacing Martin Logan Sequel panels
I recently purchased a pair of Martin Logan Sequel's from a local dealer for next to nothing, the reason for the insane price was the dealer informed me that one of the panels' output was fading due to age. Well, I bought them anyway knowing that I could get replacement panels from ML at any time. I ended up getting a pair of replacement panels from a fellow Audiogon'er and began to install them tonight. First off, and I consider myself to be fairly intelligent when it comes to this hobby, but the panel replacement was and continues to be a bit frustrating. I replaced one panel tonight and plugged the speaker back into my system expecting to hear a difference and I got one. IT WAS WAY WORSE! Talk about muffled, I'm getting sound, it's just foggy and muted. I followed ML instructions to the T however it sounds like I did something wrong. The only thing I can think of is the pigtail connector that runs from the panel to the crossover box. I had to (because ML doesn't ship new panels with the terminations for the crossover) remove the old panel, jimmy the wires from the termination (forgive me I have no idea what it's called. It's a little white box that the three wires fit into via a trio of metal clips. If you know what these are called please let me know) then replace the wires with the wires from the new panel. Removing old wires from their terminations proved to be difficult because the people over at ML seem to love solder. So, I'm thinking because those connectors are A. old, and B. crudded up with old and excess solder it's to blame for my less than stellar sound. Also, my bass has become very very boomy since replacing the one panel. I hope someone out there knows what I'm talking about and might be able to shed some light on my troubles. They really were great speakers and I couldn't bear to think that I damaged them, even when following the directions to the T. Thanks everyone.
Robinson_a  (System | Threads | This Thread)

02-19-05
  Responses
02-19-05: Jsawhitlock
I use to own Sequels and had to replace the panels also and all turned out well. The boomy base you mention was the sound I got when the panels went dead so perhaps the replacement panels are no good! Go to
martinloganowners.com as there will be great info for you. Good Luck!

Jsawhitlock  (Threads | Answers | This Thread)


04-06-05: Whitekoi
Okay,

I just replaced my panels on my quest with brand new ones from Martin Logan. I had one panel that was muted and muffled and when I replaced the panel they still sounded that way. The power supply on the circuit board was bad. Once the factory replaced the power supply those new panels really sounded good. Didn't realize how much the panels had deteriorated over time. suggest swapping power supplies between the two speakers to test for bad power supply because one should be playing great and the other sounding really bad.

Whitekoi

Whitekoi  (Answers | This Thread)


  Post your response
Subject


Your response

No html, but you may use markup tags


Username
Members only

Password